Why Workflow not started on Item Creation?

There are some cases, why the workflow was not started during item creation,

1. If you create an item using System Account, the workflow will not funtion properly or that couldn’t start.
2. The workflow start option was not enabled to “Start workflow automatically when an item was created”. Ensure this option was checked.
3. If you create and publish a workflow without enabling the Start option(Start workflow automatically when an item was created). And after some time you came and enable that start option & saves without Publishing also cause a problem.
4. Or remove the “Allow this workflow to be manually started” start option and Initiation workflow. Enable “Start workflow automatically when an item was created” option and Publish the workflow.

check the following link has the soltuoions for SharePoint Designer workflows, http://office.microsoft.com/en-us/sharepoint-designer-help/troubleshoot-workflow-errors-HA010237912.aspx#BM2
If the above solutions couldn’t solve the problem, the you have to create new workflow.

2 thoughts on “Why Workflow not started on Item Creation?

  1. Akram Reply

    Hi,

    I’ve created a list A item using a workflow of another list B. And unable to start the workflow on item creation in list A. Do u have any idea why this happens. Thanks for your help

  2. yogesh Reply

    Hi I created a simple list and created a new workflow on that list in SP designer. Workflow is set to trigger everytime a new item is created in the list. Now when I who created the workflow and is also admin on the site creates a new item, workflow is triggered and works fine but soon as I try to test with any other user workflow doesn’t trigger even though the item in the list is created. Can you please tell me what couldn’t be the issue.

    Thanks

Leave a Reply

Your email address will not be published. Required fields are marked *